Atik Cameras

Author Topic: troubles with EFW2  (Read 2005 times)

richmond

  • Newbie
  • *
  • Posts: 0
troubles with EFW2
« on: April 16, 2016, 11:39:23 PM »
I've had an ATIK 11000 and EFW2 for about a week, connected to a computer running Windows 7 on a 64-bit system.  The camera works fine, but I have problems with the filter wheel.   I'm using MaxImDL 6 for the most part, but I see similar issues when I try Artemis or other programs.

When I start MaxImDL, I can connect to the camera and filterwheel just fine.  In MaxImDL, I use the "ASCOM" entry for the filterwheel, and choose "Atik FilterWheel EFW2" in the "Advanced" tab.  The connection is fine. 

The very first time I choose a filter, the wheel rotates to that position correctly.  After that, however, the wheel does not move to the correct filter.  It usually stops after rotating by a single position. 

If I request a series of images of the form (for example) B-V-B-V-B-V, with repeated pairs of filters, the first filter is fine (B), the second filter is fine (V), but then MaxImDL hangs up: the message "Filter moving" is displayed, and the program simply stops acting.  The filter wheel moves a single position, then stops -- but MaxImDL continues to display the "Filter moving" message.

I am using the regular drivers, downloaded fresh today from your website.  I tried the Beta versions, but the behavior did not change.  I reverted to the regular drivers -- thanks for the very detailed instructions on how to do so.

Can you provide any guidance on what might be happening?


Ajay_Narayanan

  • Newbie
  • *
  • Posts: 10
Re: troubles with EFW2
« Reply #1 on: August 02, 2016, 11:44:51 PM »
Hi, Was this sorted out/ I m seeing the same issues but with Sequence Generator Pro. Thanks,

Ajay

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: troubles with EFW2
« Reply #2 on: August 03, 2016, 09:49:37 AM »
Hi Richmond / Ajay,

There was a problem with the filterwheels but it should be fixed now. Could you download and install the latest core installer:

www.atik-cameras.com/downloads.

You need to make sure you install any of the 'ASCOM' components you use. In particular, the 'ASCOM EFW2 filter wheel driver'.

Let me know how you get on.

Chris.

Ajay_Narayanan

  • Newbie
  • *
  • Posts: 10
Re: troubles with EFW2
« Reply #3 on: August 10, 2016, 10:09:59 PM »
Hi Chris,

I tested with the latest Aug 9, 2016 version. Filter changes look snappy in a bench environment. However there are some stability issues. I've emailed the details to support@atik in response to a query from Vince. Thanks for your help so far.

Ajay

dragracingdan

  • Newbie
  • *
  • Posts: 1
Re: troubles with EFW2
« Reply #4 on: September 14, 2016, 12:11:10 AM »
I'm also having trouble with the EFW2 and SGP. I keep getting error messages even with the FilterWheelRunner program. I have to keep unplugging and plugging in the EFW2 to get it to connect and even fails sometimes during a sequence.  I have tried latest drivers and the ones on the supplied disk. Windows 8.1

Thanks

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: troubles with EFW2
« Reply #5 on: September 16, 2016, 04:19:34 PM »
Hi Everyone,

I've been working to fix the bugs some people are seeing with the EFW2 filter wheel and I think I have some answers. I've uploaded a new version of the ASCOM EFW2 driver to dropbox:

https://www.dropbox.com/s/25kraspe4ee5ras/AtikEFW2ASCOMSetup.zip?dl=0

You need to make sure you have the latest version of the core software installed first: (www.atik-cameras.com/downloads).

Then run that file. If you could email me at ChrisG@atik-cameras.com with the results that would be great.

Thanks

Chris.

mikeyscope

  • Newbie
  • *
  • Posts: 4
Re: troubles with EFW2
« Reply #6 on: October 02, 2016, 12:40:03 AM »
Hi Guys

I was out tonight... first time in ages since updating the core software in early September, kept getting unhandled exception error when trying to setup the filters in the filter wheel runner for EFW-2  :-\

I removed all the core software from computer... restarted computer and did a fresh upload from website tonight (2nd October), again keep getting unhandled exception error when attempting to setup filters in the runner for EFW-2  :-\

Luckily I had the supplied disc that came with my 414EX so after removing the fresh download I uploaded the core software from disc, the filter wheel runner strangely works perfectly.  ???

Hopefully this will be solved in next core software update...

My computer... windows 10 (64bit)

Mike

Ajay_Narayanan

  • Newbie
  • *
  • Posts: 10
Re: troubles with EFW2
« Reply #7 on: October 03, 2016, 05:14:28 AM »
I tried the new core software dated Sept 28, 2016 downloaded from the Atik site. Happy to report that the filterwheel driver performed with no glitches during a quick bench-trial. The lengthy "moving..." message doesn't appear. Connections are swift. Atik FiterRunner and SGP report identical results after a filter change. Did not get any exception upon pressing the setup button, before or after connection. My SGP version is 2.5.1.17.

Thank you Chris!

Ajay

kkara4

  • Newbie
  • *
  • Posts: 2
Re: troubles with EFW2
« Reply #8 on: November 06, 2016, 04:18:53 AM »
hi guys
i am having big problems with the EFW2 out of the box and am unable to download any software off the atik website (all i get are corrupted zip files, ive tried two different machines, same thing, and ive tried over multiple days).
any chance the 64 bit beta driver for the EFW2 and the core software can be linked to dropbox Chris?  then i can use the ascom driver you linked (i assume that is 64 bit)?

thanks!

Krishan

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: troubles with EFW2
« Reply #9 on: November 07, 2016, 10:42:46 AM »
Hi Krishan,

Could you try using the 'Alternative download' on the website. The main one can be a bit temperamental.

Chris

kkara4

  • Newbie
  • *
  • Posts: 2
Re: troubles with EFW2
« Reply #10 on: November 07, 2016, 09:07:21 PM »
Thanks Chris, vince got in touch with me and gave me the same suggestion - this worked and i have the installer extracted.  I note that the latest version of the core software was released 28/10/16, so does this already include the updated EFW2 driver you dropbox linked above?

Thanks!

Krishan

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: troubles with EFW2
« Reply #11 on: November 08, 2016, 09:59:54 AM »
Hi Krishan,

The latest installer will have the latest EFW2 driver too. If you can try it out and let me know if it works, that will be great.

Chris