Atik Cameras

Author Topic: Issue booting Infinity Software when Atik Air connected  (Read 1151 times)

Cedar

  • Newbie
  • *
  • Posts: 4
Issue booting Infinity Software when Atik Air connected
« on: October 21, 2016, 03:21:02 AM »
I am running into an issue where when Atik Air is connected, the Infinity software will not start on the main computer. Atik Air runs, and shows that the Raspberry Pi is connected. However, when I click on the Infinity icon to start it up, a process shows up in background processes, instead of the application area of the task manager, and no window opens. If I click the icon again, another Infinity background process opens, but still no window. If I open the Infinity software before connecting Atik Air, it opens no problem, but when I start Atik Air up, the Infinity software shows no camera. If I close the Infinity software, it will not reopen, as mentioned earlier.

I did the advanced setup with a Raspberry Pi 3, running Raspian Jessie with Pixel. I am attempting to get it working Atik Air working over Wifi. The infinity software works fine with the USB connection, but will not connect using Atik Air. Curiously, I was able to get it working a couple of weeks ago with a Rasbperry Pi 2 running an older version of Raspian Jessie, using a Wifi dongle.

Any help is appreciated.

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: Issue booting Infinity Software when Atik Air connected
« Reply #1 on: October 21, 2016, 09:04:57 AM »
Hi Cedar,

Sorry to hear you're having problems. One quick question: Are you using the latest version of the software? AtikAir now runs all the time (in the windows tray). I've also created a new infinity version. Could you try the latest version and see if the same problem occurs? (The Raspberry Pi does not need updating)

Chris.

Cedar

  • Newbie
  • *
  • Posts: 4
Re: Issue booting Infinity Software when Atik Air connected
« Reply #2 on: October 21, 2016, 04:13:16 PM »
Thanks for the help Chris. Yes, it was the latest Infinity Version with the saturation controls, etc. I saw that Atik Air now runs in the windows tray as well. Also, we are running Windows 10 on the main computer.
« Last Edit: October 21, 2016, 04:34:16 PM by Cedar »

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: Issue booting Infinity Software when Atik Air connected
« Reply #3 on: October 21, 2016, 04:52:36 PM »
Hi Cedar,

I've just tried this myself and I think I've found the problem. I'm uploading a new version now, so check back in a couple of hours and it should be on the website (version 4.1.0.7)

Chris.

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: Issue booting Infinity Software when Atik Air connected
« Reply #4 on: October 21, 2016, 06:24:18 PM »
Hi Cedar,

The latest is on the website now. Just so you know, the bug was in the service, not infinity, so the installer will only prompt you to reinstall the service.

Chris

Cedar

  • Newbie
  • *
  • Posts: 4
Re: Issue booting Infinity Software when Atik Air connected
« Reply #5 on: October 21, 2016, 10:37:53 PM »
Awesome, I'll give it a try as soon as I can.

anders.stange

  • Newbie
  • *
  • Posts: 1
Re: Issue booting Infinity Software when Atik Air connected
« Reply #6 on: October 23, 2016, 03:24:02 PM »
I had the same problem starting Infinity software and I can confirm that the 4.1.0.7 fix seems to have solved the issue. It now works fine.

Anders

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: Issue booting Infinity Software when Atik Air connected
« Reply #7 on: October 24, 2016, 09:40:29 AM »
Excellent. Thanks Anders

astro_1

  • Newbie
  • *
  • Posts: 14
Re: Issue booting Infinity Software when Atik Air connected
« Reply #8 on: October 25, 2016, 06:22:15 PM »
Thanks for the update Chris! I thought I was losing my mind trying to get Infinity to load to test my adhoc(now access point) on the pi

Jeff

Cedar

  • Newbie
  • *
  • Posts: 4
Re: Issue booting Infinity Software when Atik Air connected
« Reply #9 on: October 28, 2016, 05:11:32 AM »
Hey Chris, I was able to try it now. The whole Atik Air system did work, which is great. However, I did have a few other problems. One problem was that while on Atik Air and the Find, Frame and Focus mode, if pressed play, switched to video mode, and then switched back to Find, Frame, and Focus, then the green pill in the top left turned red, but still said "Infinity". Another problem was that if I switched between play and stop rapidly, say if I double click on the icon, it would also turn the pill red as in the other problem. The final problem was that I could not get the Atik to reconnect via USB, so I went back to the old version of software that I had. Thanks for your help with this, I really appreciate it.

ChrisGolden

  • Atik Staff
  • Full Member
  • *****
  • Posts: 124
Re: Issue booting Infinity Software when Atik Air connected
« Reply #10 on: October 28, 2016, 04:26:43 PM »
Hi Cedar,

I've managed to recreate it here and think I've found the cause of the 'red pill' issue. The camera was disconnecting everytime an exposure was stopped (which happens automatically if you switch between modes, with an exposure of 3 seconds or more). One thing I've noticed is that it is very slow to stop an exposure when using the atik air (It takes a couple of seconds). I'm not sure why this is and I'll have to investigate our raspberry pi code to find out what's going on. However, I'm uploading a new version of the software now, so if you check back in an hour or so, it should resolve your problems listed above.

I'll try and look into the slow stop exposure issue next week and let you know how I get on. Let me know if you have any more issues.

Chris.

Cedar

  • Newbie
  • *
  • Posts: 4
Re: Issue booting Infinity Software when Atik Air connected
« Reply #11 on: October 30, 2016, 02:48:44 AM »
Awesome, thanks Chris. I too noticed that it took a long time to stop the exposure, best of luck figuring it out.
« Last Edit: October 30, 2016, 02:55:30 AM by Cedar »