Atik Cameras

Author Topic: ATIK Ascom driver hanging (MaximDL)  (Read 668 times)

snowy911

  • Newbie
  • *
  • Posts: 3
ATIK Ascom driver hanging (MaximDL)
« on: December 03, 2016, 09:36:48 AM »
Hi All,
Posted a similar note on the Maxim DL forum as it my system has just started hanging since I believe the latest ASCOM ATIK driver update:

 I've been using an ATIK 383 for the last 3 years, and since the last month have been experiencing issues with the ASCOM ATIK Driver I believe.
 If I start power up my Camera first, then start my PC and run FocusMax, which in turn start The SKY X and Maxim DL, automatically connecting to my scope and cameras, MAXIM DL freezes at the point where it attempts to connect my ATIK 383 camera. If I go into task manager and shut down the ASCOM ATIK Driver it unfreezes, although of course now cannot connect to the camera.
 I have only experienced this issue since the last ASCM ATIK Driver update. It's obviously not the end of the wold as I simply remember to start the PC first, then power up my devices, but thought I'd raise it on this forum in case others are experiencing. for reference I use an Aviosys 9258 for remote power to by Obs with my PC BIOS configured to boot on power up)
Maxim log showing a successful start up at 07:47:22 then shut down at 07:48:39 (boot PC, then power up devices), followed by an unsuccessful start up at 07:52:28 (power up all at the same time, or devices first then PC), and yes only 1 line.

 Successful
 07:47:22*2 ____________ 2016-12-03 ____________
 07:47:22*1 MaxIm DL Version 6.13 started on OBSERVATORY
 07:47:23$3 Connected to camera 1 "ASCOM" (CCDPlugASCOM.dll)
 07:47:23$3 Connected to camera 2 "SX Universal" (CCDPlugSXUniversal.dll)
 07:47:23$3 Connected to filter wheel 1 "SX Wheel" (CCDPlugSXFW.dll)
 07:47:26$9 Connected to ASCOM.SoftwareBisque.Telescope
 07:47:31$10 Connected to FocusMax.Focuser
 07:48:39$3 Disconnected from filter wheel 1 "SX Wheel"
 07:48:39$3 Disconnected from camera 2 "SX Universal"
 07:48:39$3 Disconnected from camera 1 "ASCOM"
 07:48:40$9 Disconnected from telescope
 07:48:40$10 Disconnected from focuser
 07:48:46*1 MaxIm DL Version 6.13 exited

 Unsuccessful
 07:52:58*1 MaxIm DL Version 6.13 started on OBSERVATORY

 FocusMax logs tell a more detailed story:

 Successful
 07:47:11 FocusMax Version 4.1.0.42
 07:47:12 Regional setting: United Kingdom '.'
 07:47:12 ASCOM Platform: 6.2
 07:47:12 NOVAS Astrometry Engine is connected
 07:47:21 Telescope: Driver for telescope connected through TheSky
 07:47:21 Telescope connected = True
 07:47:21 ...Current Az: 180.00 deg Alt: -51.41 deg
 07:47:22 PinPoint is found. To verify Full version is installed press
 07:47:22 Test PinPoint button in Preferences/AcquireStar/PinPoint
 07:47:22 Configuration: Default
 07:47:22 Trace: Off
 07:47:22 Diagnostics:
 07:47:22 X1:634670505742684C2B2F3864434D614B6D746C6E78413D3D
 07:47:22 X2:5974496238556E4F4F5541364A626F6D585A6F6A53513D3D
 07:47:22 X3:5579537A3569517A6B4F4F795677737543616A546873683038
 07:47:22 X3:58455331586767354536772F52384B6A53383D
 07:47:22 X4:704D634339483248453853687834685972614E7974673D3D
 07:47:22 X5:6657525878626F37417650446843505A384F53456E513D3D
 07:47:22 X6:4735786E30764E6E466B3076624E32324778663259544B3461
 07:47:22 X6:6E316C684B53414B5764557875684A63376168786D764C4765
 07:47:22 X6:6D7167417A66415548694B706A2F
 07:47:22
 07:47:22 System 1: MySystem1
 07:47:24 ...Camera control 1: MaxIm DL/CCD V 6.13
 07:47:24 ...Camera 1: ASCOM
 07:47:24 ...Camera 1: Connected = True
 07:47:24 ...Camera 1: Sensor 3362 X 2537
 07:47:25 ...Focuser 1: LakesideAstro V2 Focuser
 07:47:25 ...Focuser 1: Connected = True
 07:47:25 ...Focuser 1: Absolute = True
 07:47:25 ...Focuser 1: Guard band = 0
 07:47:25 ...Focuser 1: Max travel = 10000
 07:47:25 ...Focuser 1: Startup position = 6662
 07:47:25 ...Focuser 1: Temperature = 6.5
 07:47:25 ...Filter wheel 1: SX Wheel
 07:47:25 ...Filter wheel 1: Connected = True
 07:47:25 ...Filter slot: 1
 07:47:25 ...Filter: Green
 07:47:26 ASCOM Telescope Driver for TheSky. ==> tracking on


 UnSuccessful: (with the main difference being failed to start camera)
 07:52:44 FocusMax Version 4.1.0.42
 07:52:45 Regional setting: United Kingdom '.'
 07:52:45 ASCOM Platform: 6.2
 07:52:45 NOVAS Astrometry Engine is connected
 07:52:56 Telescope: Driver for telescope connected through TheSky
 07:52:56 Telescope connected = True
 07:52:56 ...Current Az: 180.00 deg Alt: -51.41 deg
 07:52:57 PinPoint is found. To verify Full version is installed press
 07:52:57 Test PinPoint button in Preferences/AcquireStar/PinPoint
 07:52:57 Configuration: Default
 07:52:57 Trace: Off
 07:52:57 Diagnostics:
 07:52:57 X1:634670505742684C2B2F3864434D614B6D746C6E78413D3D
 07:52:57 X2:5974496238556E4F4F5541364A626F6D585A6F6A53513D3D
 07:52:57 X3:5579537A3569517A6B4F4F795677737543616A546873683038
 07:52:57 X3:58455331586767354536772F52384B6A53383D
 07:52:57 X4:704D634339483248453853687834685972614E7974673D3D
 07:52:57 X5:6657525878626F37417650446843505A384F53456E513D3D
 07:52:57 X6:4735786E30764E6E466B3076624E32324778663259544B3461
 07:52:57 X6:6E316C684B53414B5764557875684A63376168786D764C4765
 07:52:57 X6:6D7167417A66415548694B706A2F
 07:52:57
 07:52:57 System 1: MySystem1
 07:53:02 Failed to start camera!
 07:53:02 Verify camera model in MaxIm
 07:53:03 Failed to start camera!
 07:53:03 Verify camera model in MaxIm
 07:53:03 ...Camera 1: ASCOM
 07:53:03 ...Camera 1: Connected = False
 07:53:03 ...Focuser 1: LakesideAstro V2 Focuser
 07:53:03 ...Focuser 1: Connected = True
 07:53:03 ...Focuser 1: Absolute = True
 07:53:03 ...Focuser 1: Guard band = 0
 07:53:03 ...Focuser 1: Max travel = 10000
 07:53:03 ...Focuser 1: Startup position = 6662
 07:53:03 ...Focuser 1: Temperature = 6.5
 07:53:03 ...Filter wheel 1: SX Wheel
 07:53:03 ...Filter wheel 1: Connected = True
 07:53:03 ...Filter slot: 1
 07:53:03 Error reading filter name modFilterWheel.GetFilterName
 07:53:03 ...Filter: No filter wheel detected
 07:53:05 ASCOM Telescope Driver for TheSky. ==> tracking on

Any constructive thoughts greatly appreciated!

snowy911

  • Newbie
  • *
  • Posts: 3
Re: ATIK Ascom driver hanging (MaximDL)
« Reply #1 on: December 03, 2016, 10:45:57 AM »
Sorry forgot to include ASCOM logs:
Successful:
09:35:49.056 Atik Camera               Driver version 7.0.4.18147, Driver Id ASCOM.Atik.Camera
09:35:49.056 Atik Camera               Constructor completed
09:35:49.056 Connected                 set True, API Version 712, find 192, connecting to ID 0, HSC True, connected to camera 0
09:35:49.369 Properties                properties Protocol 795, nPixelsX 3362, nPixelsY 2537, PixelMicronsX 5.4, PixelMicronsY 5.4, ccdFlags 0, cameraFlags 84, Description ATIK-383L, Manufacturer ARTEMIS CCD, set PrechargeMode to ICPS, set FIFO to true, GetProcessing None, GetMaxBin 255, 255, hasShutter {0}.  (HEX[68][61][73][53][68][75][74][74][65][72][20][7B][30][7D][2E])
09:35:49.462 Connecting                numTemperatureSensors 1
09:35:49.462 GetCoolingInfo            Connecting - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:35:49.462 Connecting                CoolingInfo flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling
09:35:49.462 Connecting                minExposure 0.2, CanFastReadout True IsColour False, BayerOffsetX 0, BayerOffsetY 0 description ATIK-383L
09:35:49.494 Connected                 completed
09:35:49.494 CameraXSize               get 3362
09:35:49.494 CameraYSize               get 2537
09:35:49.494 MaxBinX                   get 8
09:35:49.494 MaxBinY                   get 8
09:35:49.494 PixelSizeX                get 5.4
09:35:49.494 PixelSizeY                get 5.4
09:35:49.494 CanAbortExposure          always true
09:35:49.494 CanAsymmetricBin          always true
09:35:49.494 CanPulseGuide             get False
09:35:49.494 CanStopExposure           always true
09:35:49.494 Description               ARTEMIS CCD: ATIK-383L (192)
09:35:49.494 ElectronsPerADU           not implemented
09:35:49.509 FullWellCapacity          not implemented
09:35:49.509 HasShutter                get True
09:35:49.509 MaxADU                    get always 65535
09:35:49.509 HasShutter                get True
09:35:49.648 CCDTemperature            get 7.21, LastCount 0
09:35:49.648 HeatSinkTemperature       no sensor
09:35:49.648 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:35:51.773 CCDTemperature            get 7.21, LastCount 1
09:35:51.773 HeatSinkTemperature       no sensor
09:35:51.773 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:35:54.273 CCDTemperature            get 7.21, LastCount 1
09:35:54.273 HeatSinkTemperature       no sensor
09:35:54.273 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:35:56.774 CCDTemperature            get 7.21, LastCount 1
09:35:56.774 HeatSinkTemperature       no sensor
09:35:56.774 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:35:59.274 CCDTemperature            get 7.21, LastCount 1
09:35:59.274 HeatSinkTemperature       no sensor
09:35:59.274 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:36:01.774 CCDTemperature            get 7.21, LastCount 1
09:36:01.774 HeatSinkTemperature       no sensor
09:36:01.774 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:36:04.274 CCDTemperature            get 7.21, LastCount 1
09:36:04.274 HeatSinkTemperature       no sensor
09:36:04.274 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:36:06.775 CCDTemperature            get 7.21, LastCount 1
09:36:06.775 HeatSinkTemperature       no sensor
09:36:06.775 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:36:09.275 CCDTemperature            get 7.21, LastCount 1
09:36:09.275 HeatSinkTemperature       no sensor
09:36:09.275 GetCoolingInfo            CoolerPower - flags Cooling, Controllable, OnOffControl, SelectablePower, SetPointCooling, level 0, minlvl 0, maxlvl 255, setpoint 358426
09:36:11.322 Connected                 set False, 
09:36:11.322 Connected                 set to false


Unsuccessful:

09:38:51.615 Atik Camera               Driver version 7.0.4.18147, Driver Id ASCOM.Atik.Camera
09:38:51.615 Atik Camera               Constructor completed
09:38:51.615 Connected                 set True,

thanks