Atik Cameras Forum

Support (Please note, this is primarily a user forum, for direct Atik support, please email => Accessories => Topic started by: pieter koolen on October 20, 2015, 10:34:59 am

Title: Waiting for filter wheel?
Post by: pieter koolen on October 20, 2015, 10:34:59 am
I had to install a new notebook (windows8.1).
Latest version of MaximDL incl all updates.
ATIK Core as per yesterday.

For camera control I ticked Artemis HSC.
For the efw2 I ticked Ascom in the Ascom filter wheel chooser. Via advanced I chose Atik FikterWheel EFW2.

When I start the exposure the following messages appear: filter moving and waiting for filterwheel (the last one in the camera dialog box).
The wheel turns to the required filter upon ticking the filter in the filter drop box.
So locked.

Anyone familiar with this issue and the solution?
Title: Re: Waiting for filter wheel?
Post by: joelshort on January 07, 2016, 04:06:13 am
I have a similar problem.  I'm using SequenceGeneratorPro, which uses the ascom driver for the EFW2.  When I first power on and connect the filter wheel in SGP, the filter wheel reports it is "moving" even though the wheel is not physically moving.  I can't start the exposure sequence because SGP can't move the filter wheel to the correct filter.  If I unplug the filter wheel and power it back on, the FW will report correctly, starting up on filter 1.  This is repeatable. 

I did not experience this problem before recently updating to the latest Atik drivers due to installing on a new computer.

I don't know if my issue is related but thought I would mention it here just in case.
Title: Re: Waiting for filter wheel?
Post by: sferlix on January 07, 2017, 06:24:27 pm

I've the same problem.
Many times I have to unplug the FW to make things working.
It's really a mess because I loose a lot of time and very often I've also to reboot the PC ... could it be a drivers issue ?

thanks in advance for your help.
Title: Re: Waiting for filter wheel?
Post by: freestar8n on February 04, 2017, 11:08:44 pm
I appear to have the same problem.  I have had an efw2 for several years and it worked well until I installed drivers sometime in 2016.  Now it fails erratically and hangs during imaging sessions with sgp.  I have been installing the latest drivers ever since and it still has the problem.  This tends to cut imaging sessions short to 1-2 hours - which is a big loss on a good night.

Title: Re: Waiting for filter wheel?
Post by: Kinch on February 11, 2017, 11:05:58 am
Did this problem ever get sorted for people?

I have been using the EFW2 for a couple of years at least. I had no problems  (like mentioned here) until late last year....and that was only after updating the driver. When I tried to go back to the old driver (removing ALL Atik drivers and software first) it was apparent that everything was still not right...I was still getting hangs....SGP waiting on the filter wheel which showed "moving" for way too long on the SGP screen.

I then bought an second hand Atik 450M camera and luckily the seller passed on the disk. This is an older camera (relatively speaking) which was great...I now had the older driver for the EFW2 as well. Before installing, once again I removed the Atik software and drivers as before. BUT this time I went into the Windows registry and found traces of the old installs...which I also removed. I then reloaded the drivers from the disk......and I have had no problems with the EFW2 hanging since then.

Perhaps someone from Atik will notice this and take it onboard......they might better understand what is going on.

Title: Re: Waiting for filter wheel?
Post by: joelshort on February 11, 2017, 01:26:03 pm
How did you find and remove the Atik references in the registry? 
Title: Re: Waiting for filter wheel?
Post by: Kinch on February 11, 2017, 02:03:31 pm
Hi Joel,

I think I passed you an older driver once before and I dare say that one will be OK. Maybe even the new ones will be OK if the registry is cleared of any traces from previous installs. This I don't know for sure though.

WARNING: This is for all readers of this post....Please don't mess with the Windows registry if you are unfamiliar with tinkering in there. Do something wrong and it could mess your computer up completely. It is a big & real risk.

First I removed all Atik Software via the Control Panel/Programs & Features.
Right click on the Win start logo (bottom left of screen). Click on "RUN" and open REGEDIT. (Type that in)
Now you are into the registry and you will find the EFW entries under:  HKEY_LOCAL_MACHINE, then under SOFTWARE, then under CLASSES.
I removed all entries connected with Atik.Efw and then reloaded the software again. So far things have been fine.

Hope that gets it for you.
Title: Re: Waiting for filter wheel?
Post by: joelshort on February 11, 2017, 02:06:56 pm
Yes, you did pass me the old driver and that one has worked fine.  Long story short, I sold the EFW2 I had and want to remove all traces from the registry.  But now I think I'm going to buy another EFW2  :)  I still have the old driver.
Title: Re: Waiting for filter wheel?
Post by: joelshort on February 11, 2017, 02:30:33 pm
Using Edit/Find in the registry editor, I found several instances of Atik stuff in HKEY_CLASSES_ROOT as well as under HKEY_LOCAL_MACHINE.

I haven't changed anything yet.  I did export the registry.  I'm guessing I have nearly 100 entries in the registry to Atik stuff. 
Title: Re: Waiting for filter wheel?
Post by: DMouse on February 17, 2017, 03:01:15 pm
Just to add, I am also having the filter wheel moving issue. I brought the wheel into the house and ran it with the top off connected directly to the laptop. When the error occurred, the wheel was moving but stopping half way between filters. The only way to reset was to power it off and on again, and this didn't always fix it.
I haven't tried the registry delete yet, but that is my next task.

Clear Skies

Title: Re: Waiting for filter wheel?
Post by: nlondonlad on February 20, 2017, 07:23:42 am
Another one - I'm hitting this too, using Maxim this time.  Maxim reports 'waiting for filter wheel'.  If you disconnect and try to reconnect, it throws an ASCOM error.  Power cycling the wheel resolves it.

Can someone point me at the older driver that you think fixes this?  Any idea when Atik support will fix the issue in the newer drivers?
Title: Re: Waiting for filter wheel?
Post by: Kinch on February 20, 2017, 05:01:21 pm
I know that perhaps more than one person was in direct contact with Atik about this problem. (This forum is not for direct contact with the manufacturers about specific problems!). Can anyone shed a light on what way they reacted other than saying to use the latest version of the driver? Obviously for some, there is an ongoing problem....the answer to which is not just re-installing an older driver. (The old drivers are not available on the Atik site anyway - as far as I am aware).

"nlondonlad"....I would suggest that you go to the 'Contact Us' section of the site and pass on your findings directly to Atik and see how they advise you to proceed.
Title: Re: Waiting for filter wheel?
Post by: Kinch on February 23, 2017, 02:59:41 pm is a recent post on another forum....may help you??? Again, talking about EFW2 apparently 'freezing'

"Whenever this has happened to me, tightening the motor tension adjustment screw (beside the USB port) has fixed it. Oh, except for one time there was a frayed thread stuck in one of the alignment holes that needed to be removed. "