Atik Cameras Forum

Support (Please note, this is primarily a user forum, for direct Atik support, please email => Accessories => Topic started by: vladutz on June 22, 2012, 05:20:49 pm

Title: ASCOM control EFW-USB1
Post by: vladutz on June 22, 2012, 05:20:49 pm
recently got this filterwheel. Any idea how to control this via the ASCOM driver? I use ASCOM 6.

I can see it comes with an Atik ASCOM driver (apart from the system driver), however when I try to install it  it says ASCOM 5 is required.

Any idea how I can use this wheel on the ASCOM 6?
Title: Re: ASCOM control EFW-USB1
Post by: jonathan on August 14, 2012, 02:49:40 pm

Sorry not to have replied to this - another member has drawn my attention to it.

The latest core software installer provides the option to run an ASCOM 6 compliant installer for the EFW1 USB filterwheel - if you download it from the top of our downloads page at and run it, you will then need to select the option "ASCOM driver for Atik USB filterwheel" in the "Select Additional Components" window.

Best regards,

Title: Re: ASCOM control EFW-USB1
Post by: BILL110366 on August 23, 2012, 07:00:43 pm

Quite new with all this, so forgive me if I miss something :)

I have a USB1 FW, and try to get it ON with my ASCOM setup.

I did all updates (ver 6 SP1 and also ticked the USB FW during the ASCOM Core installation.

Now everytime I start the program, I get a little Window, saying either "Connect" or "Setup"

I may click either option, I always have an exception, talking about CLID and a long key.
I clicked on detail:
Any idea?


Consultez la fin de ce message pour plus de détails sur l'appel du débogage
juste-à-temps (JIT) à la place de cette boîte de dialogue.

************** Texte de l'exception **************
System.Runtime.InteropServices.COMException (0x80040154): La récupération de la fabrique de classe COM pour le composant avec le CLSID {78B6AF10-6C12-41B0-8DA9-533271F5F05E} a échoué en raison de l'erreur suivante : 80040154.
   à System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
   à System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
   à System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
   à System.Activator.CreateInstance(Type type, Boolean nonPublic)
   à ASCOM.DriverAccess.MemberFactory..ctor(String progId, TraceLogger ascomDriverTraceLogger)
   à ASCOM.DriverAccess.FilterWheel..ctor(String filterWheelId)
   à FilterWheelTester.Form1.btConnect_Click(Object sender, EventArgs e)
   à System.Windows.Forms.Control.OnClick(EventArgs e)
   à System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.ButtonBase.WndProc(Message& m)
   à System.Windows.Forms.Button.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Assemblys chargés **************
    Version de l'assembly :
    Version Win32 : 2.0.50727.5456 (Win7SP1GDR.050727-5400)
    CodeBase : file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
    Version de l'assembly :
    Version Win32 :
    CodeBase : file:///C:/Program%20Files%20(x86)/Common%20Files/ASCOM/FilterWheel/FilterWheelCommander.exe
    Version de l'assembly :
    Version Win32 : 2.0.50727.5460 (Win7SP1GDR.050727-5400)
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/
    Version de l'assembly :
    Version Win32 : 2.0.50727.5456 (Win7SP1GDR.050727-5400)
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/System/
    Version de l'assembly :
    Version Win32 : 2.0.50727.5462 (Win7SP1GDR.050727-5400)
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/
    Version de l'assembly :
    Version Win32 : 6.0.10028.2207
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/ASCOM.DriverAccess/
    Version de l'assembly :
    Version Win32 :
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/ASCOM.Interfaces/
    Version de l'assembly :
    Version Win32 : 6.0.10028.2207
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/ASCOM.Utilities/
    Version de l'assembly :
    Version Win32 : 3.5.30729.5420 built by: Win7SP1
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/System.Core/
    Version de l'assembly :
    Version Win32 : 8.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/
    Version de l'assembly :
    Version Win32 : 2.0.50727.5456 (Win7SP1GDR.050727-5400)
    CodeBase : file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
    Version de l'assembly :
    Version Win32 : 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase : file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms.resources/

************** Débogage JIT **************
Pour activer le débogage juste-à-temps (JIT), le fichier de configuration pour cette
application ou cet ordinateur (machine.config) doit avoir la valeur
jitDebugging définie dans la section
L'application doit également être compilée avec le débogage

Par exemple :

    < jitDebugging="true" />

Lorsque le débogage juste-à-temps est activé, les exceptions non gérées
seront envoyées au débogueur JIT inscrit sur l'ordinateur
plutôt que d'être gérées par cette boîte de dialogue.

Title: Re: ASCOM control EFW-USB1
Post by: bhfisher on August 28, 2012, 09:45:46 pm
Seems that I have the same problem,
Havent used the kit all summer, upgraded the Laptop and running Win 7 Pro.

Everthing installes and works OK apart from my EFW1.

Running Ascom 6SP1. Have tried both the latest core software installer and the Filter wheel CD version on the Website. The CD Version downloads with ASCOM V5, tried running with this without sucess. ASCOM 6SP1 can be configured to install the CD version of the software by adding the Atik Setup programme to the “ForcePlatformVersion in the Profiler Explorer, unfortunatly didnt help either.

Maxim DL has the Atik Filter Wheel in its ASCOM list but wont connect.

Attempting to connect using the Atik filter wheel control software produces the 'exception error' similar to the last post.

The issue seems to be Windows not accepting the driver. It recognises the device but wont install the driver (either version). Have followed the Win7 Driver installation instruction on the website. Have also manually pointed the device at the driver location, let it search and pointed it at the C drive with subfolders selected, still wont load.

Any advice would be appreciated if anyone manages to solve the problem.

Title: Re: ASCOM control EFW-USB1
Post by: BILL110366 on September 16, 2012, 10:30:44 am

Atik Staff??? any idea?
Title: Re: ASCOM control EFW-USB1
Post by: Jerryaxe on November 29, 2012, 12:43:07 pm
Hi Rui

Any idea?

is this bug resolved cause I need to upgrade to the latest version of ASCOM and don't want to loose my filter wheel?


Title: Re: ASCOM control EFW-USB1
Post by: shiraz on December 01, 2012, 12:35:56 pm
same problem, but found what I was doing wrong.

The core installer told ASCOM6 about the filter wheel, but did not install the Windows driver.
TheWindows 7 driver  loading process  worked, but only when I downloaded the "drivers" package  from the "software" section - not when I download the USB1 filter wheel specific drivers from the "installation CD" section of the download page (which of course is what I did first).
Now running well under ASCOM6, but took about 3 hours of hair pulling to get to that state - needs some Atik housekeeping
Title: Re: ASCOM control EFW-USB1
Post by: zalt on February 04, 2013, 08:16:22 pm
Thank you shiraz, for sharing your success recipe.

No success or me though, on 64-bit Windows 8.

Bought the EFW-USB1 a year ago.
At that time I installed and used the wheel on a 32-bit Windows 7 notebook, using the CD ( and upgraded to ASCOM 6SP1.
The filter wheel worked ok, but wasn't useful in this configuration as the computer was too slow for proper USB camera transfer.

Just got a powerful Win8x64 notebook, but cannot get past the the COMException error when clicking Connect or Setup after starting C:\Program Files (x86)\Common Files\ASCOM\FilterWheel\FilterWheelCommander.exe.
I have tried a number of times, with "all posible combinations". Also when starting fully clean, in this order:

Running as administrator does not help.
There's also a shortcut for C:\Program Files (x86)\Atik\ArtemisCCD\FilterWheelRunner.exe, but the Connet-chekbox (only enabled control) apparently does nothing.

Atik support, any clue?
I assume this is not because of Windows 8, simply because the installer material is a bit messy.
Thanks anyway.

And I would have saved time and bought the USB2 wheel if I could find email support for Atik. (reminding me of my upcoming CCD purchase for my Hyperstar)

Title: Re: ASCOM control EFW-USB1
Post by: Jerryaxe on March 03, 2013, 02:42:52 pm
Atik team,

I have the same issue as the others.
I bought a new laptop for imaging with Windows 7 pro and ascom V6.
My camera is fully recognized by the Ascom driver (Atik 4000
) and I can get whatever software to work with it.
For the filter wheel v1, I used the different drivers on the website and nothing works. Even the filterwheel soft can't connect to it and gives me the error message below (same as Bill 110366).
I tried all dirvers and USB1 drivers as well..... don't ask I already tried.

The error message is still the same ie error 80040154

What do we need to make it work? The filter wheel is still working perfectly on my old laptop with Ascom 5.5 and the old drivers (windows XP).... Unfortunately, my old computer is about to die and works only once in a blue moon which is why I have to change.

A clear answer is required now otherwise I will have to bin my fully fonctional filterwheel due to lack of support and buy a new one.
If nothing is done, I will be happy to share the news on all forums in France, UK, Australia and US.

Jerry, a non impressed customer....

P.S : the filterweel works under artenmis capture ???? but only on this one and nothing else.
Title: Re: ASCOM control EFW-USB1
Post by: Steve on March 08, 2013, 08:44:04 am
Good Morning,
Sorry to be slow to response to this but please do read the sticky notes at the top of the boards.  If you would like a response from Atik please contact Support at
The EFW1 is a discontinued product so we can’t promise it will be working with modern PC hardware indefinitely.  However it does work fine on our win7 64 bit systems under ASCOM with the software updates on our website.  If you would like Atik help with these Support at is the place to go.
Title: Re: ASCOM control EFW-USB1
Post by: Steve on March 08, 2013, 08:48:05 am
Hello Again,

Should have added this on to the end of the last message.  It might help


The FilterWheelCommander program cannot be used to control the USB1 filterwheel with 64-bit versions of Windows.   However, the USB1 filterwheel can be controlled both using Artemis Capture and through ASCOM.  To get this working, you will need to install the drivers (instructions and download link are in the "Drivers" section of our downloads page,  ensure that the ASCOM framework is installed if ASCOM control is required (see, then run the Atik core software installer (available for download at the top of our downloads page, checking the "ASCOM driver for Atik EFW1 filterwheel" option in the "Select Additional Components" window if ASCOM control is required.   Incidentally, "FilterWheelRunner" only works with EFW2 filterwheels.
Title: Re: ASCOM control EFW-USB1
Post by: Jerryaxe on March 14, 2013, 09:30:47 pm
Thanks Steve

Problem solved. You absolutely need to use the usb1 driver otherwise it does not work on windows 7 64.

For those who still have an issue, please let me know and I will try to help.

Steve, regarding the support, I think that provided we use the ascom platform to use the filter wheel, there should be no real difference in the code. W8 will be sonn W9 as it was only developped to get back on track with the tablets which have 99% dna of w7.
The main change may come from ascom newer versions....
Title: Re: ASCOM control EFW-USB1
Post by: bergleopard on March 22, 2014, 11:33:46 pm
I was pending with this nearly one year ago, no Chance to make this filter wheelrunning on Windows 7 64. I wrote to Atik Support; got no answer.
This night I tried it again to install this EFW USB1 on my new Windows 7 64bit labtop
Now I saw this postings , and tried to follow the described procedure. No success via ascom , Astroart or Atik software
But even my supplier (Teleskop-Service) did not got any solution or answer from Atik and can solve this problem with his educated technical People.
I realy do not understand why Atik was still selling such products when it does not work on current Computer Software like Windows 7 64 bit and announed by time how to procede and supply the Software update and let the customers searching arround, unbelievable bad habit; its realy a very bad bad Support and behaviour of this Company.
 >:( >:( >:(