Atik Cameras

Author Topic: EFW2 filterwheel problems: can't communicate properly [solved]  (Read 3310 times)


  • Newbie
  • *
  • Posts: 1
      I've owned an Atik 11000 CCD and EFW2 filterwheel
since March, 2016.  I've used it many times over this period,
and acquired a lot of good photometry. 

       Last fall, the filterwheel would occasionally cause
problems: our control software, MaximDL running under
Windows 7, would fail to connect to it properly.  But that
only happened 10% or so of the time.

       This summer, it is happening more frequently -- and
now, it happens just about all the time.  When I try to
connect to the camera and filterwheel, all seems to go
well .... but when I try to change filters, or just take an
image, I see a message from MaximDL

              filter is moving ...

and the program continues to wait for the filterwheel

       When I first plug power into the filterwheel, I feel
(and can see) it rotating.  It makes two complete revolutions,
then moves one or two more positions and stops so that
one of the filters is positioned properly.  Good.
When I ask the filterwheel to move to any filter, the
wheel moves exactly one position, regardless of the
requested filter.  Not good.  I tried replacing the USB
cable -- same behavior.

       After unplugging and replugging five or six times
during one session, the filterwheel suddenly did start
behaving properly.  It rotated to the requested filter just
as it should, and continued to do so for some time before
I closed down.

       Can anyone give me advice on solving this problem?
I see that other users have reported similar problems
in the past. 

       Thanks very much in advance.
« Last Edit: August 16, 2019, 03:51:19 pm by richmond »


  • Newbie
  • *
  • Posts: 1
Re: EFW2 filterwheel problems: can't communicate properly
« Reply #1 on: August 16, 2019, 03:50:24 pm »
Here's an update: the problem very likely lies with the USB communications, not with the hardware.  Andrew from Atik Support kindly asked if the USB connection involved a hub; and, in fact, it did.  When I made a direct connection between the filterwheel
and a USB port in the computer itself, the software worked fine.

So, my suggestions for myself and others with similar problems:

  • if possible, connect the filterwheel directly to a port on the computer
  • if not possible, check the USB hub you are using; it might be degrading the signal