Atik Cameras

Author Topic: Unable to connect to Atik EFW2  (Read 1979 times)


  • Guest
Unable to connect to Atik EFW2
« on: January 07, 2020, 06:07:10 pm »
I purchased an EFW2 back in 2016, to use with an ASI1600. The filter wheel has worked great for years, up through Oct. 8th this year, which was the last time I was able to image. Most of the time since then was cloudy, however the last week has been clear...and I've spent the whole week trying to get my EFW2 working.

I recently had to reinstall my computer, and in the process I decided to start with a clean Windows 10 install. I've been able to get all of my other devices working, including several cameras (including a QHY5L-II which is generally known as a problematic camera, but it works fine), ZWO filter wheels, a NiteCrawler, EQMOD with an Atlas and an AP Mach 1. The one problem device is my Atik EFW2. I've had it connected for short periods a couple of times, but once I shut everything down for the night, the next day or night when I try to connect again, it simply will not work.

I've tried multiple USB cables. I have tried connecting directly, rather than through a USB hub (however, this is not a viable scenario for me, as my configuration requires the use of a hub). I have tried several versions of the Atik software. I am not sure what it is called today, but I've used several 5.x versions, back to 5.0.1 I think, as well as the latest. Changing the software/driver version does not seem to have affected anything.

I am not really sure if a driver for the EFW2 itself is actually being installed. As far as I can tell, it shows up in Device Manager as "USB Input Device/HID-compliant vendor-defined device", and the driver it is using is a Microsoft default driver...I see no indication that a vendor-specific driver that actually labels the device as an Atik EFW2 is being used.

I am connecting through ASCOM, from SGP (latest release, but I have also tried half a dozen previous beta builds as well). Unlike most of the other drivers I use, which will time out after a period of time if the connection cannot be made or fails...the Atik EFW2 ASCOM driver simply hangs when it tries to connect and sits there forever. It does not time out. The other problem is, the moment I open up the ASCOM driver config window in SGP (wrench icon next to the filter wheel selection, not the chain icon), it immediately hangs. I don't even have the option of enabling the Trace checkbox (although I am not sure where any trace information is logged), it just immediately tries to connect (or perhaps just enumerate known devices) and hangs.

I have tried both Atik FilterWheel and Atik FilterWheel 2. These names have changed since October. Whichever version of the driver I was using back then, the name of the device listed in ASCOM was "Atik FilterWheel EFW2" based on the json equipment profile info from some of my other .sgp sequence files (sadly, it seems SGP is by default configured to save and overwrite sequences automatically, so the sequence I've been trying to use no longer has its original config from October, however it should have been the same as several other sequences I've run this year.) In any case, neither Atik FilterWheel nor Atik FilterWheel 2 works. The few times I have been able to connect, it was always with Atik FilterWheel 2 (I am not sure how this is determined, or why my sole filter wheel has shown up under filter wheel #2...)

I am desperate to get this issue figured out. My current setup has all devices wired through a RigRunner 4005 and a StarTech USB 3.0 powered hub that are both mounted on my telescope. I then have a single usb cable and a single power cable running through the Mach 1 mount, to which I connect them directly to AC power (very clean power, runs through a PowerWerx (or actually probably actually WRM, IIRC) AC/DC battery auto-switch and conditioner, and the signal is a nice clean, low noise flat 13.4v DC signal based on my oscilloscope (no DC battery is in use at the moment, they don't last long in the winter). The USB is then connected to a powered USB 3 repeater cable (yes, both the hub and the cable are powered).

I have tried all the various ports on the hub. All other devices work fine on any port, including the high speed ZWO cameras operating in video mode. So I wouldn't expect the hub to be an issue, as it seems to handle much higher data loads, throughput and speeds from other devices. The hub is also powered from the RigRunner, and voltage tests show over 13V at the power connection to the USB hub.

What could be causing this connectivity issue with the Atik EFW2? I've ordered a couple of new, short gold plated USB 2 Type-A to Mini-B cables. Outside of the cable to my camera, the other cables don't have the gold plated connectors, but since this scope often spends many nights outside I've decided to make them all corrosive-free gold plated. I am not sure if that will improve things or not.

Thank you for any reply.

As a side note, the current driver really seems to need some work. Aside from the fact that it instantly hangs when you open the ASCOM Config window (I am pretty sure all it is trying to do is enumerate, an enumeration of devices shouldn't block the UI nor hang the driver perpetually), if the device actually connects, then the list of filters is actually too large for the size of the window. It extends below the bottom of the window, underneath the Trace checkbox and the Ok and Cancel buttons. The window cannot be resized and it is not scrollable, so I can only edit filters up to #7 (I have the 9-pos 1.25" wheel right now). It would be really great if we could get the driver fixed so that enumeration doesn't hang the UI, so that at the very least the Trace option could be edited. Further, it would  be nice if a timeout was implemented, so that IF the enumeration hangs, it doesn't just hang forever. It would also be nice to have a retry option, if enumeration fails...and ideally some kind of notification THAT enumeration of devices failed. Finally, it would be nice if the ASCOM driver config window could at least be resized, so that larger lists of filters could be edited. BTW, I use 4k screens (on all of my computers, desktops, laptops, etc.) at 125% or 150% scale, depending on the may be that the scaling is affecting the rendering of the any case, it is only partially usable IF it does not immediately hang upon being opened.


  • Atik Staff
  • Sr. Member
  • *****
  • Posts: 282
Re: Unable to connect to Atik EFW2
« Reply #1 on: January 14, 2020, 03:08:41 pm »

Would you mind emailing us at and we can look into this for you.

Best regards