Atik Cameras

Author Topic: INDI_ATIK_CCD with Kstars 3.5.9 crashes upon launch  (Read 468 times)

Altouch

  • Newbie
  • *
  • Posts: 21
INDI_ATIK_CCD with Kstars 3.5.9 crashes upon launch
« on: July 04, 2022, 10:57:11 pm »
I've had my Atikbase running for a while now.  It generally works well, with a few lessons learned.  There are still some quirks, but generally works fine.  The plate solving is really good.   

I made the mistake of upgrading to Kstars 3.5.9 from 3.5.8.   Now my INDI_ATIK_CCD driver crashes upon launch.  I would downgrade to 3.5.8 if I can figure out how to do that.  But, because the driver crashes, it is back to being just a power distribution box.  I've included a partial trace log below, and attached a complete log if that is helpful. 

Any clues on how to fix this, or get an updated driver, or retreat to 3.5.8 would be useful. 

[2022-07-04T15:23:55.041 UTC DEBG ][           org.kde.kstars.indi] - Connection to INDI server is successful
[2022-07-04T15:23:55.043 UTC INFO ][           org.kde.kstars.ekos] - "INDI services started on port 7624."
[2022-07-04T15:23:55.060 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-07-04T15:23:55: startup: /usr/bin/indiserver -v -p 7624 -m 1024 -r 0 -f /tmp/indififo7d81ee66 "
[2022-07-04T15:23:55.061 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-07-04T15:23:55: listening to port 7624 on fd 3"
[2022-07-04T15:23:55.061 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: start indi_atik_ccd"
[2022-07-04T15:23:55.061 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: Starting driver indi_atik_ccd"
[2022-07-04T15:23:55.061 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-07-04T15:23:55: Driver indi_atik_ccd: pid=1285 rfd=4 wfd=7 efd=8"
[2022-07-04T15:23:55.061 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-07-04T15:23:55: Client 5: new arrival from 127.0.0.1:35962 - welcome!"
[2022-07-04T15:23:55.062 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2022-07-04T15:23:55.141 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-07-04T15:23:55: Driver indi_atik_ccd: indi_atik_ccd: symbol lookup error: indi_atik_ccd: undefined symbol: _ZThn4768_N4INDI3CCD13GuideCompleteE12INDI_EQ_AXIS"
[2022-07-04T15:23:55.141 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2022-07-04T15:23:55.144 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-07-04T15:23:55: Driver indi_atik_ccd: stderr EOF"
[2022-07-04T15:23:55.144 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "2022-07-04T15:23:55: Driver indi_atik_ccd: Terminated after #0 restarts."
[2022-07-04T15:23:55.144 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2022-07-04T15:23:55.145 UTC CRIT ][           org.kde.kstars.indi] - INDI driver  "indi_atik_ccd"  crashed!
[2022-07-04T15:23:55.167 UTC DEBG ][           org.kde.kstars.indi] - INDI Server:  "Child process 1285 died"

Altouch

  • Newbie
  • *
  • Posts: 21
Re: INDI_ATIK_CCD with Kstars 3.5.9 crashes upon launch
« Reply #1 on: July 05, 2022, 07:30:06 pm »
All fixed now. I got a response on the INDI forum. The driver was not linked properly. The command line in the console (or terminal) window to fix it is:

sudo apt-get update && sudo apt-get -y install --reinstall indi-atik libatik libindi1

Be sure to have the last item on the command line end with the digit 1 and not a lower case L.

Kstars 3.5.9 is now running and talking to my Atik cameras.