Atik Cameras

Author Topic: error FT_CreateDeviceInfoList  (Read 7249 times)

ge2000

  • Newbie
  • *
  • Posts: 3
error FT_CreateDeviceInfoList
« on: March 11, 2012, 06:32:37 PM »
Hi All,

After installing the latest version of Artemis Capture on a new pc (XP) I get the following error:
 failed to load function FT_CreateDeviceInfoList and a lot of other similar errors. After ignoring about 4 errors the program starts and seems to work.  The camera is a Atik 16HR.

Does anyone know a solutions for this?

Thanks in advance,

Ge
 

Lex

  • Full Member
  • ***
  • Posts: 244
  • We do it at night...
Re: error FT_CreateDeviceInfoList
« Reply #1 on: March 20, 2012, 12:26:51 AM »
Hello,

are you using a FutureTech device?

Best

Lex
CGEM, C11, TS Carbon Apo Triplet 90/600, TS Carbon UNC 254/1250, Atik 383l+, EFW2,
TSOAG, Lodestar....

ge2000

  • Newbie
  • *
  • Posts: 3
Re: error FT_CreateDeviceInfoList
« Reply #2 on: March 21, 2012, 09:10:19 PM »
No, not that I'm aware of.  The camera and 2x rs232-usb adapters are connected through an external powered usb hub to the PC. 

On m previous install I had no problem at all but now with the latest versions of the Atik/Artemis software and/or drivers this issue arises.

Ge

Lex

  • Full Member
  • ***
  • Posts: 244
  • We do it at night...
Re: error FT_CreateDeviceInfoList
« Reply #3 on: March 21, 2012, 11:21:38 PM »
It is possible that your PC doesn't recognize the RS232 adapter.
I recommend that you check this prior to reinstalling the drivers.
I had the same problem on my Mac...

Best

Lex
CGEM, C11, TS Carbon Apo Triplet 90/600, TS Carbon UNC 254/1250, Atik 383l+, EFW2,
TSOAG, Lodestar....

ge2000

  • Newbie
  • *
  • Posts: 3
Re: error FT_CreateDeviceInfoList
« Reply #4 on: March 24, 2012, 06:48:47 PM »
The RS232 adapters are working fine. A focuser, filterwheel and Gps receiver are connected and all are working as expected.
So I really think the Atik (16hr) drivers are buggy. I will try to extract the older driver and give it a try with thatone.

Ge

ezpecas

  • Newbie
  • *
  • Posts: 1
Re: error FT_CreateDeviceInfoList
« Reply #5 on: May 17, 2012, 05:23:57 PM »
Hi.

I am having the same behaviour with my Atik383+.

Any suggestions?

Regards JE

Kaidan

  • Jr. Member
  • **
  • Posts: 60
    • Astrophotographie à l'île de la Réunion
Re: error FT_CreateDeviceInfoList
« Reply #6 on: May 17, 2012, 05:42:11 PM »
That's because of a stupid DLL called FTD2XX.dll.

The DLL can be found in the Program Files (x86)\ArtemisCCD and called FTD2XX_NET.dll.

Just copy / paste it in the directory of every program that is going to use the ATIK CCD and rename it to FTD2XX.dll.
Jeremy Skuza
Astrophotographie à l'île de la Réunion
TMB Optical 130 Signature Series + 3" corrector
Losmandy G11 "O&V" [NS + Spacer] Gemini II
DS : ATIK 383L+, Astronomik LRGB | AG / P : ATIK Titan

jonathan

  • Atik Staff
  • Newbie
  • *****
  • Posts: 14
Re: error FT_CreateDeviceInfoList
« Reply #7 on: May 23, 2012, 04:18:19 PM »
Hello,

This issue is caused by an incompatible version of FTD2XX.DLL being installed, and it should be fixed by running the latest version (1.7) of the core software installer which is available on our downloads page.

Regards,

Jonathan
(Atik)

Lex

  • Full Member
  • ***
  • Posts: 244
  • We do it at night...
Re: error FT_CreateDeviceInfoList
« Reply #8 on: January 09, 2013, 07:15:22 AM »
so, it is something with a future tech device or software  ;D
CGEM, C11, TS Carbon Apo Triplet 90/600, TS Carbon UNC 254/1250, Atik 383l+, EFW2,
TSOAG, Lodestar....