Atik Cameras

Author Topic: ATIK EFW2 USB broken  (Read 3753 times)

Mirandola

  • Newbie
  • *
  • Posts: 3
ATIK EFW2 USB broken
« on: March 23, 2014, 10:56:25 am »
I got a problem. Today my filer wheel fell on the floor. It's my fault.  Unfortunately USB cable that was connected damaged some connectors in USB socket. USB filter wheel now  doesn't react for Maxim DL commands now.  Probably it's necessary to change USB socket (I hope not full electronic). Any solutions? I think only sending to ATIK for repair is solutions right now.

NickK

  • Full Member
  • ***
  • Posts: 249
Re: ATIK EFW2 USB broken
« Reply #1 on: March 23, 2014, 09:59:53 pm »
Send an email to Support@Atik-Cameras.com

I stepped on my 383L's USB cable, ripping out the USB socket - they repaired it and sent back the next day.
ATIK 383L+, Titan, 16IC, EFW2, OAG | Pentax 105SDP | NEQ6
Author of the ATIK OSX Drivers and AOSX - Astronomy on OSX

Mirandola

  • Newbie
  • *
  • Posts: 3
Re: ATIK EFW2 USB broken
« Reply #2 on: March 24, 2014, 06:45:41 pm »
I sent e-mail but no response. Do you have problem with support contact also?

NickK

  • Full Member
  • ***
  • Posts: 249
Re: ATIK EFW2 USB broken
« Reply #3 on: March 24, 2014, 10:04:36 pm »
No, not normally. They're usually quite responsive.
ATIK 383L+, Titan, 16IC, EFW2, OAG | Pentax 105SDP | NEQ6
Author of the ATIK OSX Drivers and AOSX - Astronomy on OSX

vince

  • Atik Staff
  • Sr. Member
  • *****
  • Posts: 277
Re: ATIK EFW2 USB broken
« Reply #4 on: March 24, 2014, 10:38:43 pm »
Hi Mirandola,

Sorry for the delay, we have been re-organizing the offices and taking on more staff over the last few weeks so are running slightly behind! Catching up now though! You should have your reply.
Best regards
Vince :)