Atik Cameras

Author Topic: Severe Vertical Banding / Lines - Color Horizon  (Read 5144 times)

bwa

  • Sr. Member
  • ****
  • Posts: 298
Severe Vertical Banding / Lines - Color Horizon
« on: February 24, 2018, 12:19:17 am »
I've used a mono ATIK 428Ex since 2012, have a mono ATIK Infinity camera and recently sold a color Infinity camera in anticipation of the Horizon.  The only problem I ever had with ATIK hardware is a minor glitch running the 428Ex with the Infinity software; quickly resolved.

That is until I received my new Horizon color camera last Wednesday.  Supposed to be a simple matter to power up the camera, connect it to a USB 3 port and, voila, images; NOT, NOT and NOT!  Nothing but problems to this point in the process!

Day 1:

I received the new color Horizon this afternoon and have tried getting it operational; no success!

Something appears to accumulate, sort of like a memory overflow, and the display falls apart then simply stops.  The software doesn't crash, the display just gets really noisy then stops updating even though the software appears to be still capturing images.

I've downloaded and installed the latest Infinity and Artemis software.  I've tried running the software on two i7 Windows 10 laptops.  I've tried three USB 3 cables.  I tried using the Horizon with both the Infinity and Artemis software; same result.  I've totally uninstalled and reinstalled the software.  No solution.

I can partially resolve the problem by unplugging the power from the Horizon camera, waiting a few seconds then powering it up again; no need to restart the software. It'll capture another 4-5 images then the display stops again.  It almost appears like the camera is having an buffer overflow error and hanging??.  However, even the images captured before the next hang have severe vertical banding.

The attached image is a 100% crop from an image saved off the screen at the point the display hangs.

I also tried the Test Infinity software ATIK support forwarded back in December when I was having problems with the 428Ex.  Same result.

I fired up the mono Infinity and 428Ex cameras to see if something was wrong with the laptop or software.  Both of them run perfectly!

Day 2:

I loaded the ATIK software onto an old i7 HP laptop that only has USB 2 ports.  The Horizon actually runs a little better on this laptop.  It looks like the software makes an attempt to pause until the image file is downloaded and displayed.  This (the pause) doesn't happen on my laptops with USB 3 ports.  The images displayed still have severe vertical banding as shown previously but the display doesn't crash until 9-10 images have been displayed.

I set the Infinity software to capture subs (*.FIT files).  The subs show the same severe banding as the on-screen display and blank (black) after the camera appears to hang, i.e.: the Infinity software still thinks something is coming from the camera worth saving even after the screen display stops?

Day 3:

Further to this Horizon problem.  I checked all the Error files and there were no errors reported for the period during which the Horizon wouldn't display a picture (as I said previously, the software ran perfectly but the camera appears to stall).  These files have been sent to ATIK support but I suspect they'll not tell them much.

I also fired up a powered USB 2 hub and put it between the camera and a laptop with a USB 3 port.  This seems to have slightly resolved a part of the problem, i.e.: the camera no longer seems to hang but the Infinity software still doesn't pause to allow images to download and display, and the displayed images still have severe vertical banding / lines and every couple of images simply displays as either white or black with all sorts of vertical artifacts.

I have a powered USB 3 hub on order; delivery early next week.

As one last attempt to resolve this issue this afternoon, I started swapping out power supplies.  I had been running the camera with a 2.5 amp 12 volt power supply.  Fired everything up with a 5 amp 12 volt power supply; no joy!  Fired everything up from 12 volt battery power; still no joy!

To this point, after three days of changing pretty much everything I can think of, I have yet to get even one reasonable image off the camera!  Since I've had great success in the past with ATIK products this is VERY frustrating!!!

To this point I haven't had any response from ATIK Support, so...  If anyone has any ideas what may be causing this, I would be VERY interested in your suggestions!?

bwa

bwa

  • Sr. Member
  • ****
  • Posts: 298
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #1 on: February 24, 2018, 12:37:00 am »
...
The attached image is a 100% crop from an image saved off the screen at the point the display hangs.
...
I should note the image attached to my original image had an exposure of 0.05 sec.; however, I can provide images with exposures all the way up to 120 sec. with the same or worse vertical banding and similar artifacts.

bwa

bwa

  • Sr. Member
  • ****
  • Posts: 298
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #2 on: February 24, 2018, 06:15:58 am »
Further to this Horizon camera problem...

I fired up the Horizon camera with the latest version of SharpCap in a last ditch attempt to see if I could get the camera operational.  I can definitely rule out the Infinity and Artemis software as the problem since I get exactly the same severe vertical banding in SharpCap images, all the way from 1 sec. to 120 sec. exposures!!

However, one thing I did notice in SharpCap was the software waited until the camera's image was downloaded and displayed before it commenced capturing the next image.  This does not appear to happen in the Infinity software; it simply keeps capturing pictures until things seem to overflow??  Artemis does appear to wait until the download is complete before proceeding with the next capture, I think?

bwa

Iria-Atik

  • Atik Staff
  • Jr. Member
  • *****
  • Posts: 76
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #3 on: February 26, 2018, 12:26:23 pm »
Hi bwa,

Thank you for contacting our support team and once again sorry for this inconvenience. We'll keep you updated about the new version of the code that should address this issue, hopefully in just a few days time.

Iria
Iria

bwa

  • Sr. Member
  • ****
  • Posts: 298
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #4 on: February 28, 2018, 08:04:05 pm »
Hi bwa,

Thank you for contacting our support team and once again sorry for this inconvenience. We'll keep you updated about the new version of the code that should address this issue, hopefully in just a few days time.

Iria
I read something about new firmware for the Horizon?  Where is it and how do I install it?  Might help??

bwa

chakel

  • Newbie
  • *
  • Posts: 14
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #5 on: February 28, 2018, 08:17:19 pm »
It appears in the Change Log posted on the downloads page and is included with the new core software update (27-Feb).

bwa

  • Sr. Member
  • ****
  • Posts: 298
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #6 on: March 01, 2018, 01:00:19 am »
It appears in the Change Log posted on the downloads page and is included with the new core software update (27-Feb).
Yup, I got that but how does one do an update of the camera's firmware?

bwa

chakel

  • Newbie
  • *
  • Posts: 14
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #7 on: March 06, 2018, 12:30:15 am »
bwa, I had confirmed with Atik staff that all that's needed is to install the sw update. They had replied "The firmware update is built into the core software installer, so you
 don't need to do anything special other than download the latest version of the core software from our website." Well done on Atik's part I'd say.
Cheers,
John Chakel



bwa

  • Sr. Member
  • ****
  • Posts: 298
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #8 on: March 25, 2018, 05:58:47 pm »
The problems with my Horizon have been resolved. ATIK sent a replacement Color Horizon which works perfectly, although I have yet to try it under the stars. However, I've captured ~2000 subs out my living room window in every mode the Infinity software allows and I've also tested it in ATIK's Artemis software; equally successfully. 

It did require two #13 neutral density filters to cut daylight to a level where I could use a short enough exposure to get a picture. 0.001 sec. is the shortest exposure the camera will accept and it was too long.

The most recent Core Software release also fixed a few outstanding glitches with both the Infinity and Horizon cameras, like 2x2 binning not working, a sporadic software crash when changing binning while capturing subs, a buffer overflow on the Horizon when shooting short subs, i.e.: when download speed was slower than the exposure. My mono Infinity and ATIK 428Ex also works very nicely with the most recent Infinity software.

ATIK Support came through as did my dealer; thank you!

Now we wait for some good imaging weather to put it to work! And wait... and wait...

bwa

dpaul

  • Full Member
  • ***
  • Posts: 134
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #9 on: March 26, 2018, 01:30:52 am »
Can you tell me what was the latest download version ?

I recently had to go back to an earlier software level (about 4 weeks go), may a new level has just been released.

David

bwa

  • Sr. Member
  • ****
  • Posts: 298
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #10 on: March 26, 2018, 02:44:24 am »
Can you tell me what was the latest download version ?

I recently had to go back to an earlier software level (about 4 weeks go), may a new level has just been released.

David
SetupAtikCamerasUniversal-4.2.1.8 is the latest I have and it works well.  A number of previous glitches fixed.

bwa

DuaneS

  • Newbie
  • *
  • Posts: 4
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #11 on: March 26, 2018, 04:35:26 am »
I would stay very far away from this camera. I have had 2 of them and I tried the second one tonight and compete failure. I have zero interest in troubleshooting this either. Did that on the first camera. Want to plug in and use.

bwa

  • Sr. Member
  • ****
  • Posts: 298
Re: Severe Vertical Banding / Lines - Color Horizon
« Reply #12 on: March 27, 2018, 08:25:38 am »
I would stay very far away from this camera. I have had 2 of them and I tried the second one tonight and compete failure. I have zero interest in troubleshooting this either. Did that on the first camera. Want to plug in and use.
Always going to be some problems with new hardware / software platforms.  I guess I fully anticipated some unexpected glitches.  I've been involved in new hardware / software solutions for 40+ years and have never had one go totally according to plan!  The Horizon is a new beastie for ATIK and there will be teething problems...  Converting the Infinity software to work with 400 series cameras at the same time probably didn't help the situation!?

bwa